FFixer

By Vaughan Chandler Last update Mar 9, 2011 — Installed 15,736,522 times.

Home Page - Extend Width

in
Subscribe to Home Page - Extend Width 24 posts, 12 voices



Kris78424 User
FirefoxWindows

This is my script:

if (prefs['HomeStretch']) {
addStyle('.fbx #globalContainer { width:auto; margin:auto 75px; } .fbx #fbf-page-head-container { width:auto; }');
if (prefs['TopBarFixed']) { addStyle('.fbx #headNavOut { width:' + ($('#contentCol').clientWidth-16) + 'px; }'); }
}

As of this morning it worked fine. Now, after turning on my computer after I got home from work, the posts and comments are back to FB's default width.

___This Morning:_______________________Currently:

CO__P-O-S-T-S__CO ----> CO__POSTS______CO
LU__-Comments__LU ----> LU__comm.______LU
MN__P-O-S-T-S__MN ----> MN__POSTS______MN

 
Texan_POd User
FirefoxWindows

Yeah, seems it broke a couple of hours ago. The stretch to browser width is ok. The header width is ok. The comments are NOT stretched on mine.

The following in the Advanced > CSS section still works in the header section.

/* These 3 work together to use full length of header */
#pageHead {width:99% !important; position:fixed !important; z-index:auto; }
#blueBar {width:100% !important; position:auto !important; z-index:auto; }
#headNav {width:auto; }

 
Kris78424 User
FirefoxWindows

It depends on what your settings already are. I modified my script a little, so it would function and appear how I'd like. So, that CSS really messed up the header section for me.

Everything looks how it should, except for the middle column (news feeds & comments).

 
Texan_POd User
FirefoxWindows

I'm using FFixer 2.3.0 unmodified. I use some CSS for cosmetic stuff but have that removed right now until the rest is back working. I also don't display the right column usually and it doesn't make a difference if I do.

As you observed, the news column is where the problem is. NO stretching...

 
DoSMaN User
FirefoxWindows

I have the same issue.... the middle column doesn't stretch anymore...

 
wolfgrrl User
FirefoxWindows

Same here - not stretching the news feeds.

 
RainyShadow User
OperaWindows

This works fine for me:
div#contentCol>div#contentArea {width: 69% !important;}
form.commentable_item>ul {width: auto !important;}

Reduce the % value if the feed gets pushed under the right column.

Or try my CSS file - http://bit.ly/FB_my_CSS

 
DoSMaN User
FirefoxWindows

Rainy it works fine :D

I adjusted to 80% because i have wide monitor but its ok now :D
Thanks :D

 
Nigh7mar3 Scriptwright
OperaWindows

thanks Rainy but not so clear

find

addStyle('.fbx #globalContainer { width:auto; margin:auto 7px; } .fbx #fbf-page-head-container { width:auto; }');

add after ( modify the width % if layout broken )

addStyle('div#contentCol>div#contentArea { width: 71% !important; } form.commentable_item>ul {width: auto !important;}');

 
Dink Scriptwright
FirefoxWindows

Create a userstyle in stylish with the following code:
--------------------------------------------------------------------------

@namespace url(http://www.w3.org/1999/xhtml);

@-moz-document domain("facebook.com") {

}#contentArea {padding-left: 5px !important; margin-left: 0px !important;
width: 790px !important; padding-right: 5px !important; }

---------------------------------------------------------------------------

Adjust the width px value to suit your liking.

 
RainyShadow User
OperaWindows

I noticed my code above breaks if i shrink the browser window.
This should work better, more tolerant to smaller screen/window sizes (although it might make the right column too wide on wide screens):

div#contentCol.hasRightCol>div#rightCol {width: 28% !important; padding-right: 0px !important;}
div#contentCol.hasRightCol>div#contentArea {width: 68% !important;}
form.commentable_item>ul {width: auto !important;}
Add it to Configure FFixer > Advanced > Custom CSS , then press the Save button.
I also updated my CSS file to include the change.

Nigh7mar3, what is not so clear? I use pure CSS while your code seems to be JS/GM. Is yours a patch for the FFixer code itself?

Dink, consider using non-fixed width.

P.S. no offense to anyone, just my 2 cents :P

 
Kris78424 User
FirefoxWindows

Nigh7mar3: That worked like a charm! Thank you so much!!!

 
wolfgrrl User
FirefoxWindows

RainyShadow: thanks - that worked!

 
AkaVeve User
FirefoxWindows

RainyShadow: Works here too. I don't understand why the modifications aren't done in FFixer, officially...

Anyway... 10x

 
Balki Bartok... User
FirefoxWindows

Thanks Rainy! Your fix worked great!

 
Vaughan Chan... Script's Author
FirefoxX11

Haven't gotten a chance to work on FFixer in a while. I'll try to get this fixed by the end of the year.

I'm glad to see the Custom CSS feature is being used to fix broken features. I was hoping that would happen if I was unable to update FFixer quickly :)

 
Bryan Jensen User
ChromeWindows

This topic needs a bump so I now is a good time to say RainyShadow's custom CSS works great!

 
Vaughan Chan... Script's Author
FirefoxX11

I've included RainyShadow's code in today's beta release, FFixer 2.3.0.1

 
Texan_POd User
FirefoxWindows

Rainy's code assumes using the Right Col. (I believe).
As I prefer the real estate, I don't display the R Col.

Is there an option to span across that space when it's not used?

The following used to work fairly well....

/* HARD CODING a stretch scenario */
div#contentCol>div#contentArea {width: 90% !important; }
form.commentable_item>ul {width: auto !important; }

FYI: I forgot who I need to credit with providing this code, BUT IT WASN'T ME....

 
Vaughan Chan... Script's Author
FirefoxX11

Ah, right, I forgot about that. I'll update the script.

 
Dink Scriptwright
FirefoxWindows

Will this work for profile pages also?
I hope it does.

 
Asskicker2 User
ChromeWindows

Rainy's code assumes using the Right Col. (I believe). 
As I prefer the real estate, I don't display the R Col.

Is there an option to span across that space when it's not used?

The following used to work fairly well....

/* HARD CODING a stretch scenario */ 
div#contentCol>div#contentArea {width: 90% !important; } 
form.commentable_item>ul {width: auto !important; }

FYI: I forgot who I need to credit with providing this code, BUT IT WASN'T ME....

I'm having the same problem, I still can't get the Main Page to Extend OVER the right bar (I disabled it)

I'm using the beta version but that doesn't work either.

 
Texan_POd User
ChromeWindows

I'm not a power user but found it easier to use the following to end up with a usable FaceBook experience, at least until someone fixes the current FirFox version. Was up and running a parallel browser in 15 minutes (guess).

Google Chrome 8.0.552.224
http://www.google.com/chrome/intl/en/landing_ch...

Adblock Plus for Google Chrome™ BETA 1.0.25
https://chrome.google.com/extensions/detail/cfh...

FFixer 2.3.0
https://chrome.google.com/extensions/detail/hje...

Then use the CSS referenced before:

/* Get rid of “bio” section in the NEW Profile Page */
div.fbProfileByline {display: none; }

/* Get rid of “tagged photos” bar on NEW Profile Page */
div#pagelet_photo_bar {display: none; }

/* Get rid of “crap” on the right side – Adblock Plus helps */
div.ego_section {display: none; }

/* HARD CODING a stretch scenario */
div#contentCol>div#contentArea {width: 95% !important; }
form.commentable_item>ul {width: auto !important; }

Then, because I'm half-blind and old, I use these to increase the font size:

/* Original Message – font size */
.uiStreamMessage {font-size:13px !important; }

/* Comments – font size */
.commentContent {font-size:13px !important; }

 
Dink Scriptwright
FirefoxWindows

I am still able to extend my homepage and hide the right column.
I'm using the current version of Firefox with some css in ffixer and using adblock plus to hide the right column.

Using Texan's /* HARD CODING a stretch scenario */

Also, for adblock plus, I use the element hiding helper.