Large

FarmVille Wall Manager

By JoeSimmons Last update Jan 24, 2011 — Installed 1,667,649 times.

FVWM Problems Center

in
Subscribe to FVWM Problems Center 1182 posts, 166 voices



Jimmie65 User
ChromeWindows

I assume it's because snow stallion foals have no name in the posts

 
BrendaInBC User
FirefoxWindows

thanks Jimmie, I thought maybe since there's a box for them now that it would stop collecting them...but that makes sense!

 
Dave Norman User
FirefoxWindows

Susanne, Mokkun, coco, do you have any error messages relating to FVWM in the Firefox Error Console (Ctrl-Shift-J on Windoze)? I have the same problem (FVWM simply won't load on pages where it should, but only on my account) and get an error message:

Error: profID is null
Source File: file:///.../farmville_wall_manager.user.js
Line: 4668

The area of the script looks like

// Method to work on multiple accounts
var prof = $("navAccountName") || $g(".//a[.='Profile' or .='Profilo' or .='Profiel' or .='Profil' or .='Perfil']", {type:9, node:($("pageNav") || document.body)}),
    profID = $g("//a[@id='navAccountPic']/img[@alt and contains(@src, 'profile.ak.fbcdn')]", {type:9});
main.profile = prof.href.find("id=") ? prof.href.split("id=")[1].split("&")[0] : prof.href.match(main.profileRegex)[1];
main.profileID = profID.src.match(/\d+_(\d+)_\d+_[qstn]\.(jpe?g|png|[gt]iff?|bmp)/)[1];

My //a[@id='navAccountPic'/img[@alt] doesn't [contains(@src, 'profile.ak.fbcdn')]: the @src is "http://static.ak.fbcdn.net/rsrc.php/yo/r/UlIqmHJn-SK.gif", because I don't have a profile picture on my FB account.

 
Mokkun User
FirefoxWindows

Hmm, Yes it do seem I have a errormessage in the console, for pofID is null
opening it gives the following part of it selected:
main.profileID = profID.src.match(/\d+_(\d+)_\d+_[qstn]\.(jpe?g|png|[gt]iff?|bmp)/)[1];

Sidenote, I do not have a profilepicture on FB, if that is of any help to find the cause.

 
coco86 User
ChromeWindows

yes, i had the same error. I added an image to my profile and now it works :)

Thanks!!

 
Sabina User
FirefoxWindows

Hi Joe! Could you please add these items to the script? Thank you very much .

Image and video hosting by TinyPic

-------------------------------------------------

Image and video hosting by TinyPic

----------------------------------------------------

Image and video hosting by TinyPic

 
Pain N. Ass Scriptwright
FirefoxWindows

Sabina wrote:
Hi Joe! Could you please add these items to the script? Thank you very much .
Nice post! In the furure, could you put these in the FVWM Features Requests Center. Also for the others, unknown items & adopt unrecognized will pick these up until they are added to the script and there's always Dyna Grab if you want more precise control.
 
Sabina User
FirefoxWindows

But the problem is that I have marked the item "Get New or Unrecognized Items" and "Adopt Unrecognized Animals", but FVWM me those three items not collected.

 
some addict Scriptwright
FirefoxWindows

Sabina wrote:
But the problem is that I have marked the item "Get New or Unrecognized Items" and "Adopt Unrecognized Animals", but FVWM me those three items not collected.
i ran into a problem with the 'unknown' options. try turning off both, saving, then turn on just 'new/unrecognized items', and see if that helps.
http://userscripts.org/topics/60925?page=19#pos...
 
Sabina User
FirefoxWindows

I tried it, but no change, do not catch items :-(

 
some addict Scriptwright
FirefoxWindows

strange.. and i haven't seen any of those cross my wall, so i can't veryify it. pain, have you seen any of them?

sabina, try using the dynamic grabber for these, then. http://userscripts.org/topics/61754
or, if you want to see if you can get the 'unknown' options to pick them up, my last suggestion is to go through the 'troubleshooting for firefox' post here - http://userscripts.org/topics/50136?page=1#post... .

 
DLBeLL1984 User
FirefoxWindows

I hope this is the right section for this... since it seems to be a problem for me, I guess it is.

FVWM has been working fine for me since I started using it a few weeks ago, but as of an hour ago I have been having trouble. When I have it disabled Facebook works fine, but as soon as I enable it and refresh, Facebook constantly reloads like every 3 seconds and within seconds I have the following in my browser bar - "?sk=lf&sk=lf&sk=lf&sk=lf" and so on. I have no other scripts, so I don't know what is happening.

 
some addict Scriptwright
FirefoxWindows

@dlbell, if you look a page or two back, quite a few of us saw this, and it appeared to be a facebook error, not a script error. give it a few hours and see if it clears up. if not, follow the 'troubleshooting for firefox' instructions linked in my post above or in the first post of this thread, and see if that helps.

edit: i'm seeing this happening again, and the weird thing is, is that as soon as fvwm picks up a post to process, the page stops reloading and adding '&sk=lf' to the url. also, turn fvwm off and it stops happening. glancing at the code, it's probably a bug in the 'stay on most recent page' option.

 
Sabina User
FirefoxWindows

I've tried all the recommendations, but does not help anything. The problem is that my wall not only collects the three items that I made the first contribution. Snow stallion I have labeled me as well so it collects. Yesterday it was still all right, but today as I reload the new items in the shop at the farm, so the new me not collected.

 
DLBeLL1984 User
FirefoxWindows

Thank you very for the quick reply!

 
Dave Norman User
FirefoxWindows

It looks like profID isn't actually used anywhere else in the script. So I commented that line out (by putting "//" at the start:

//main.profileID = profID.src.match(/\d+_(\d+)_\d+_[qstn]\.(jpe?g|png|[gt]iff?|bmp)/)[1];

), and now it seems to be working.

 
Sabina User
FirefoxWindows

I did a screen display on the job FVWM :

http://i53.tinypic.com/2wpkl4x.jpg

 
Tech-Chef Scriptwright
FirefoxWindows

Having Issues. Keeps refreshing itself and adding &If=sk at the end of facebook.com/

 
some addict Scriptwright
FirefoxWindows

DLBeLL1984 wrote:
I have the following in my browser bar - "?sk=lf&sk=lf&sk=lf&sk=lf" and so on.
possible fix: add an sk=lf check to the if for staying on the most recent posts page -
// If enabled, stay on the Most Recent feed
var mostrecent = $g(".//a[contains(@href, 'sk=lf')]", {node:$("pagelet_stream_header"), type:9});
if(GM_config.get("mostrecent") === true && mostrecent != null && !(main.realURL.find("sk=lf"))) {
joe, ddm, thoughts? betting i added that 'wrong'. but i stopped having problems after doing so.
i see why it's doing this now - joe kindly added a check to see if 'most recent' is clickable. well, fb changed the 'most recent' link so that it is always clickable (menu), so.... boom!

@sabina: have you tried using the dynamic grabber? also, the posts for snow stallion foals are broken, as they are missing the text that identifies the animal.
 
Tech-Chef Scriptwright
FirefoxWindows

@ some addict
That worked!

 
.Hollie. User
FirefoxWindows

So how do we fix it because my page keeps refreshing like every 1 second and I don't even see the script link so I can change the setting? Thanks.

 
fgarvin User
ChromeWindows

Same here... refreshing every second... BROKE!!!

 
interflug User
ChromeWindows

Mine was doing the same thing as the above posters, adding the sk=if and refreshing every second...Once you get it to stop and open the options, I went to Basic Tech Options and unchecked "Stay on the "Most Recent" feed"...It works perfect now

 
Marco PincoP... User
FirefoxWindows

@Hollie
You fix it as some addict said (for chrome).
Go where the script is, on my pc,the dir is
E:\Documents and Settings\Sandman\Local Settings\Application Data\Google\Chrome\User Data\Default\Extensions\lmgbaoafnlapnaeilhggnhkiblingnbc\1.2.18084_0

Change E and Sandman with whatever you have on your pc and you should find it, once there, open/edit
script.js with a text editor, search for
If enabled, stay
and replace the 2 lines below with the 2 he pasted.
Worked for me.

 
fgarvin User
ChromeWindows

Thanks interflug!!!

Your post fixed it...

"Mine was doing the same thing as the above posters, adding the sk=if and refreshing every second...Once you get it to stop and open the options, I went to Basic Tech Options and unchecked "Stay on the "Most Recent" feed"...It works perfect now"