Quake Live New Alt Browser

By wn_ Last update Jan 1, 2014 — Installed 49,453 times.

question about compatibility

in
Subscribe to question about compatibility 10 posts, 3 voices



1nsider User
ChromeWindows

is there any way to make this script compatible to Firefox 3.7* builds?
The main problem there isn't to get greasemonkey goin' - you could f.ex. instead make the script to a single firefox-addon (http://arantius.com/misc/greasemonkey/script-co..., but not only does the keyboard-function (shift+R) triggers the security-manager in firefox, it still wouldn't work even without it. So, any chance?

 
wn_ Script's Author
FirefoxWindows

I haven't looked at Firefox 3.7.x yet, but you might be able to use the Add-on Compatibility Reporter (https://addons.mozilla.org/en-US/firefox/addon/...) to bypass compatibility checking for Greasemonkey.

 
1nsider User
ChromeWindows

No. Like I said, you can get greasemonkey to work in FF3.7, but the script itself (like many others) doesn't work there. I think it might have something to do with a new JavaScript Version running there.

 
wn_ Script's Author
MozillaWindows

The following configuration is working fine for me (even Shift+R):

  • Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100506 Minefield/3.7a5pre
  • Add-on Compatibility Reporter 0.4.2
  • Greasemonkey 0.8.20100408.6
  • Quake Live New Alt Browser 0.89

 
1nsider User
ChromeWindows

Thanks for checking wn_, now it's working here also with todays Minefield. I was using the 3.7a4 (Developer Preview) and couldn't get it to work, but everything is fine now. Very nice script, keep going :)

 
1nsider User
FirefoxWindows

This script unfortunately breaks again on Firefox4-beta7 (and higher). Seems like a minor issue to me. For further details please check your messages.

 
wn_ Script's Author
FirefoxWindows

Yeah, I've noticed the problem as well. Kinda been waiting to see if it gets fixed in a nightly...

 
areafix Scriptwright
FirefoxWindows

script not work (some bugs and html artefacts) with FF 4.0b9 + monkey 0.9

 
wn_ Script's Author
FirefoxWindows

Version 1.02 of this script should now work with GM 0.9... however in FF4 you'll need to comment out lines 145 (if (table.config.debug) {) through line 174 (}).

I believe that is related to the following bug: https://bugzilla.mozilla.org/show_bug.cgi?id=61...

 
areafix Scriptwright
ChromeWindows

version 1.04 + GM 0.9.1 + FF 4.0b11
still not work

http://img694.imageshack.us/img694/8420/qlnewal...

i try to cut debug on script but nothing happens :(