Greasemonkey will not detect userscripts

in Script development
Subscribe to Greasemonkey will not detect userscripts 8 posts, 3 voices



Tommy Smith Scriptwright
FirefoxWindows

In Google Chrome, I prefer Tampermonkey to make userscripts, however, every script I try on Greasemonkey v0.9.20 on Firefox 14.0 won't be detected as a userscript. They all end in .user.js but instead of a window I get to see source code when I find a new userscript and click on it's link. Is Greasemonkey v0.9.20 incompatible with Firefox Beta? Could not find any info anywhere!

 
Jefferson Scher Scriptwright
FirefoxWindows

It's absurdly easy to disable Greasemonkey by clicking its toolbar icon when you're trying to use the menu. In that case, the monkey face is faded; another click will re-enable it. I recommend always checking for that first.

 
mike cupcake Scriptwright
FirefoxMacintosh

Related to this there's a confusing bug where if you click the icon to disable GM then click the menu arrow, the 'Enabled' option is still ticked.

 
Tommy Smith Scriptwright
FirefoxWindows

Nope, it says Enable next to Greasemonkey and if I try to disable it it would require a Firefox restart as well. I already tried a reinstall of the Addon and my browser has automatically updated many times, and I still have a userscript from when it used to work in another version (forget which). But it just won't detect new ones.

 
Tommy Smith Scriptwright
FirefoxWindows

Hi,
AT first I thought you mean't the addons bar. But I do not see any icon like that shown in http://wiki.greasespot.net/images/7/7a/Win7-ff4... anywhere! Here is my browser screen right now: http://kiwi6.com/file/q0mqr4zq3y (sorry, it's a DL link) and here is my addons bar: http://kiwi6.com/file/9dvfqr9bao it's like it just stopped working one day

 
Tommy Smith Scriptwright
FirefoxWindows

Sorry for triple post :( but come to think of it, could it be my Firefox Persona that makes the button disappear?

 
mike cupcake Scriptwright
FirefoxMacintosh

If the icon's not visible then you can click Tools menu, Greasemonkey instead.

Here's some troubleshooting steps:
http://wiki.greasespot.net/Troubleshooting_%28U...

 
Tommy Smith Scriptwright
FirefoxWindows

Ah ha! That's what I had to do. Tools menu wasn't available so press Alt>Tools>Enabled and make sure a checkmark shows afterward. Thanks!