Auto Refresh

in
Subscribe to Auto Refresh 14 posts, 9 voices



thebowfamily User
ChromeWindows

It's not working at all. I have changed it multiple times from every 1 minute to 5 to 10... and nothing. I look in the log... and it's not even sending requests to update the info... can you fix this please? I hate having to click the refresh every 5 minutes personally. And if I leave the script running it never does anything because it keeps losing troop counts... so no attacks until I return and manually refresh.

 
howardmoon User
ChromeWindows

Same here. Not sure if it has ever worked for me.

 
MSeurat User
ChromeWindows

I just came here to comment on the exact same thing. LOL! I guess I am glad I am not the only one with this issue.

I know, Jawz, that you said you were really busy at work and would not have much time to get a new update out until around June or so, that is fine... but please look at this feature when you are planning out the next update. We all would so very greatly appreciate it.

 
howardmoon User
ChromeWindows

Jawz

I should add that I am also deeply in your debt. I would not be playing this game without your script.

 
MSeurat User
ChromeWindows

Thank you for the New update so much earlier than anticipated. The notes say that the sand strider was added and is trainable now - Very Cool!! - and that a few bugs were fixed. Just to note we are still having nonfunctionality with the autorefresh. I set the script to wave for my last piece of armor last night and it stuck at some point on "delay due to user march limit reached, retry in "x" seconds" as described in the console logging. This is easily bypassed with a manual refresh. Given that my auto refresh value is set at varying times in each city - this particular one, since I was waving for armor, was set at refresh every 5 minutes - it is clear that the autorefresh is still not working.

I am positive that finding a way to fix this would be of immesurable benefit to all. Thanks again and Happy Gaming to all!

 
Myrkk Scriptwright
FirefoxMacintosh

There's various reason why it stops. I've personally not had it stop because of the autorefresh not working. It's more often because the SCRIPT says I've exceeded the march limit, or No Great Dragon available.. It builds up ghost marches in the script, even though the marches and Dragon have returned and the script has refreshed the flash.

 
rosebandit Scriptwright
ChromeWindows

The Auto refresh from the options tab will not work for a very long time.
The coding is very complicated and jawz will not have time until july.

but the script refreshs itself when starting an action like attacking ,but not everytime.

i play with this issue for 5 month now and i must say, i donĀ“t miss it.
The autorefresh was helpful for the auto-features like training and building.
With using the nano-food glitch it worked perfect, but without u have to refresh by yourself

The next problem is, it seems that kabam changed the way how it handles the requests coming from the script. so for me the attack features stops after 20 requests per hour and start again after this hour.

so i recommend to train without the script, i train troops for excact 24 hours as one training queue.
Auto attack is disabled for this time and then only with a delay of 3 minutes

hope i could help you with this informations

 
thebowfamily User
ChromeWindows

I don't use it for training purposed... but for waving... and even with a nano collector activated and waving every 50-75 seconds... and auto refresh set for every 1 minute... it still doesn't refresh like it's supposed to do.

I don't get any time outs or exceeds errors at any point. So that doesn't pertain to this either.

As for the script refreshing itself just sometimes... it doesn't even do that... at all... troop counts keep disappearing and they don't show in the script unless I refresh. And it's a common trend. I have asked around... and until you rosebandit... not a single person has gotten the auto refresh to work. So I'm not sure what you are doing exactly...

 
Jawz74 Script's Author
ChromeWindows

Actually, the refresh button is updating only the main city detail (so it should also refresh marches, training and building jobs...). But some data aren't refreshed by the current process, this concerning mainly OP jobs and existing buildings.

I have to review the refresh process but I don't know how to fix it... Either I refresh only the main city and some data will miss, either I refresh all cities (main + OP) and 1) this will take time and server response won't be guaranted 2) one refresh will send a request per city/OP (so 10 requests if you have all OP). So in that case you will have quickly the error 509.

So I don't know how to fix the problem... Please note that the flash is updating only main city data (for instance when you change your tax rate). Data for noe OP are refreshed everytime you access the OP... So you don't have the problem with the flash because you access only one city at a time.
The script is dealing, for its parts, with all city/OP data in the same time...

 
thebowfamily User
ChromeWindows

Unfortunately, it's not Jawz. Even the new script version isn't working for autorefreshing purposes. And like I said... I have yet to encounter anyone beyond rosebandit who has gotten it to work for quite some time...

As for refreshing the OPs... I would like that if it would in fact work. But if the city refresh isn't working then I don't see this helping either. Something's gotta give here... just not sure how to go about it either.

 
rollingmonolith User
ChromeWindows

i'm unfortunately having issues with march-limit reached/no dragon/out of troops, hitting refresh on the info tab sorts it 9/10 but it doesn't auto refresh it. and i have it set to 1min.
means i can't leave it unattended for long periods and kinda defeats the purpose of using it. Still, i am sure u'll work it out.

Love the script tho, is the best. period.
thx Jaws

 
Grendal User
ChromeWindows

I'm having the same issue. I'll send out 9 marches, the marches hit their target then disappear from the script, rather then a return march. I've got it set for ever 5 minutes. Yet 20 minutes later I'll check it, have no marches out in my main city's muster point, yet the script is telling me the muster point is full. Makes it very hard to wave properly.

Windows xp, google chrome, I checked the console and it says ( 15:30:00 ) Messages.fetchNext BAD MESSAGE ID: Not sure if that has something to do with it or not.

 
Nick Shamas User
ChromeWindows

Hey Jawz, question... Probably a stupid, obvious question.. but, the option named:

Flash Game Auto-Refresh Every [x] Seconds/Mins/Hours ... Does that do a Toggle Flash sort of thing, or does it just read from the current data?

I know I should just try it, but if it isn't that way, that would be a pretty decent option in my opinion?

edit: sorry for the waste of a post- it won't let me delete this now for some reason? .. I answered my question ;o

 
Jawz74 Script's Author
ieWindows

Just one thing concerning the auto-refresh... The auto-refresh is requests sent to the server and is so dependent on the error 509. I mean if the attacks/waves stop due to this error, it's pretty sure that the auto-refresh will fail.
When the attacks/waves are running well, the auto-refresh is working fine for me.