Large

Feedly - Mark Previous As Read

By Michael Mangino Last update Nov 26, 2013 — Installed 69 times.

Script Summary: Adds a button to Feedly that marks items above the current item "as read".



Version: 1.17

Screenshot



Description

This script adds a button labeled mark previous read to Feedly. When clicked, all items above the currently selected one are marked as "read". If no item is selected and the list contains at least one "read", then all items above the lowest "read" item will be marked as "read".

The button added by this script provides functionality similar to the Mark previous as read operation that could be invoked after long-pressing an item in the official (but now defunct) Google Reader app for the Android platform. That is, the items above the current selection are marked "as read", regardless of whether the list is sorted by newest or by oldest. Therefore, this functionality is intended for users who read their feeds top-to-bottom, sorted oldest-to-newest.

The screenshot above shows the new button's placement in Feedly.

IMPORTANT:
  • After installing this script, you must refresh your Feedly page in your browser (not in Feedly) to see the new button.
  • Google Chrome users must have Tampermonkey to install and use this script. See the Notes section below for more information. (Firefox users may use either Greasemonkey or Scriptish.)
  • This script was developed for the latest version of Feedly, which no longer requires a Feedly extension and is available at http://cloud.feedly.com/, not http://www.feedly.com/.
  • Currently, only the Titles view of Feedly is supported.

Configuration

Auto-collapse the Selected Item


To make the selected item collapse automatically after clicking the mark previous read button, edit the script and set COLLAPSE_SELECTED_ITEM to true, as follows:

var COLLAPSE_SELECTED_ITEM = true;


Notes

Google Chrome


This script works in both Firefox and Chrome. However, in Chrome, you must have the Tampermonkey extension in order to install and use this script. With Tampermonkey installed, return to this page and simply click the Install button. Do not try to install this script via the Extensions tab in Chrome; it will not work because this script uses Greasemonkey variables, which Tampermonkey makes possible in Chrome.


Version History

1.17
2013-11-26
  • Changed URL from cloud.feedly.com to feedly.com.
1.16
2013-08-04
  • Increased max version number due to Feedly upping their version number to 17.x.
1.15
2013-07-04
  • Minor tweaks and code cleanup.
1.14
2013-07-01
  • Added support for Scriptish.
1.13
2013-06-26
  • Added "Weekend Edition" to list of excluded pages.
1.12
2013-06-26
  • Added History and Preferences to excluded pages.
1.11
2013-06-26
  • Updated button color to match Feedly's new green.
  • Added specific @include for https.
1.10
2013-06-25
  • Minor bug fix.
1.9
2013-06-25
  • Updated to work with new extension-less Feedly (version 16.x) at cloud.feedly.com.
1.8
2013-04-11
  • Added configuration option COLLAPSE_SELECTED_ITEM.
  • Minor code tweaks.
1.7
2013-04-11
  • Altered excluded pages handling to accommodate Feedly's recent changes to certain page titles.
1.6
2013-04-10
  • Added "please wait..." message to blank screen while marking previous items as read.
1.5
2013-04-09
  • Added more thorough checking of edge cases for setting document.body.style.display back to "block".
  • Enhanced version checking to allow for X.0.0 min/max values.
  • Added "Saved" to list of excluded pages.
  • Added working values to the @downloadURL and @updateURL keys in the metadata block.
  • Changed the @icon value to use https.
1.4
2013-04-09
  • Fixed excluded pages, which stopped working after Feedly updated their title format.
  • Turned off debug mode.
1.3
2013-04-09
  • Fixed bug that left the screen blank when clicking mpr button with no item selected.
1.2
2013-04-09
  • Fixed version checking issue.
1.1
2013-04-09
  • Made script incompatible with outdated Feedly version 10.2.
1.0
2013-04-08
  • Initial version.